Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000078 [NSCA] Other / Unknown feature always 2009-08-28 05:41 2016-10-25 16:55
Reporter xavierb View Status public  
Assigned To nagios_staff
Priority normal Resolution open  
Status closed   Product Version
Summary 0000078: issue with MAX_PLUGINOUTPUT_LENGTH
Description send_nsca and nsca always work on a static packet whose size is determined at
compile time. They send/receive this packet in full, even if most of it is
garbage, and compute the CRC32 over the whole of this packet.

if client and server were compiled with a different MAX_PLUGINOUTPUT_LENGTH,
they won't be able to cooperate because the CRC32 will always be wrong.

Would it be possible to modify the code to allow different size in the client and server, without breaking the functionality ?
Additional Information The issue showed up when I patched nsca 2.7.2 with a MAX_PLUGINOUTPUT_LENGTH of 8k to match nagios value. See https://bugzilla.redhat.com/show_bug.cgi?id=497847 [^] for details.
Tags No tags attached.
OS
OS Version
Attached Files

- Relationships

-  Notes
(0000337)
zpeirce (reporter)
2011-10-06 13:58

The patch here https://dev.icinga.org/issues/294 [^] would be a nice addition to NSCA can this be incorporated?
(0000372)
Xavier Bachelot (reporter)
2012-01-31 09:17

nsca 2.9.1 supports both old client (2.9 and older) using 512 as the max input plugin length and current client (2.9.1) using 4096. Only limitation afaik is the server needs to be 2.9.1 or later.
(0001764)
jfrickson (manager)
2016-10-25 16:55

Moved to github https://github.com/NagiosEnterprises/nsca/issues/10 [^]

- Issue History
Date Modified Username Field Change
2009-08-28 05:41 xavierb New Issue
2011-10-06 13:58 zpeirce Note Added: 0000337
2012-01-31 09:17 Xavier Bachelot Note Added: 0000372
2015-09-25 12:21 jfrickson Status new => assigned
2015-09-25 12:21 jfrickson Assigned To => nagios_staff
2016-10-25 16:55 jfrickson Note Added: 0001764
2016-10-25 16:55 jfrickson Status assigned => closed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker