Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000534 [Nagios Core] Core minor always 2013-11-18 04:40 2015-07-24 14:40
Reporter ovidiu_stanila View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 4.0.1
Summary 0000534: Bogus log messages 'Unknown jobtype: 10' when using process_performance_data (service_perfdata_command/host_perfdata_command)
Description When using service_perfdata_command or host_perfdata_command configuration Nagios logs a warning message for each service/host check. These warning messages look like:
[1383116400] Worker 1277: Unknown jobtype: 10
[1383116400] wproc: Unknown job type: 10
[1383116400] Worker 1279: Unknown jobtype: 10
[1383116400] wproc: Unknown job type: 10
[1383116400] Worker 1278: Unknown jobtype: 10
[1383116400] wproc: Unknown job type: 10
Additional Information Looking at the source code, I've found that these come because PREFDATA type of jobs (WPJOB_HOST_PERFDATA/WPJOB_SVC_PERFDATA:) are unhandled in worker processes.

Made a simple patch that handles this type of jobs. Actually it does no additional thing when this type of jobs is encountered.

This does the job, avoiding this type of warning messages and doesn't seem to affect the overall workings of worker processes. If any additional hooks are required for this type of jobs please update the patch.
Tags No tags attached.
Nagios Version 4.0.0
OS CentOS
OS Version 6.4
Attached Files ? file icon bogus_warnings.patch [^] (771 bytes) 2013-11-18 04:40

- Relationships

-  Notes
(0001176)
enterdavertex (reporter)
2014-04-04 16:04

How can we apply this patch ?
(0001181)
ovidiu_stanila (reporter)
2014-04-08 01:24

In the Nagios source code directory do:
# patch -p1 < bogus_warnings.patch
(0001221)
will_mike (reporter)
2014-04-29 16:07

How can we apply this patch in case Nagios is already installed - the proposed above applies the patch to the code. Does that mean you have to reinstall Nagios again?
(0001236)
ovidiu_stanila (reporter)
2014-05-05 02:25

Yes, you'll have to reinstall Nagios from source in order to get rid of those messages.
(0001325)
travissidelinger (reporter)
2014-11-25 13:02

Also confirmed, this is an issue and this patch resolves the issue.
(0001326)
mjo (reporter)
2014-11-26 09:34

Another confirmation, and the patch WORKSFORME too.
(0001354)
abrist (manager)
2015-04-07 14:04
edited on: 2015-04-07 14:04

I ran into this issue with an XI (core 4.0.8) client today. They had added the following to nagios.cfg for splunk integration:

host_perfdata_command=nagios-process-host-perfdata
service_perfdata_command=nagios-process-service-perfdata

The patch works perfect, but we had to spend quite some time cleaning up the database table nagios_logentries of wproc and Worker rows once fixed.

If the patch does not cause issues for those running a vanilla install, my suggestion is to merge it to trunk.

(0001357)
wcreech (reporter)
2015-04-10 11:33

I worked on this with ABrist, we were having a lot of problems with database logs growing extremely large and crashing the system.
  abrist applied the patch and got the db cleaned up and it seems to be good now. My only concern is when it is time to upgrade we will need to patch again if this isn't added..
(0001358)
abrist (manager)
2015-04-10 16:01

I cross-posted this tracker issue to github for more visibility;

https://github.com/NagiosEnterprises/nagioscore/issues/36 [^]
(0001359)
shashikanth_bussa (reporter)
2015-05-08 05:10

I would like to know . We have a customized nagios environment. So,when i apply the patch and install from the new source. It replacing all the data.

Is there any way to apply the patch with out reflecting the exiting customized environment.
(0001370)
jfrickson (manager)
2015-07-24 14:39

Issue fixed in github commit: https://github.com/NagiosEnterprises/nagioscore/commit/fdcf340ffa4157e1a4646e9b149760c2ac223e58 [^]

- Issue History
Date Modified Username Field Change
2013-11-18 04:40 ovidiu_stanila New Issue
2013-11-18 04:40 ovidiu_stanila File Added: bogus_warnings.patch
2013-11-18 04:40 ovidiu_stanila Nagios Version => 4.0.0
2013-11-18 04:40 ovidiu_stanila OS => CentOS
2013-11-18 04:40 ovidiu_stanila OS Version => 6.4
2014-03-17 11:00 prandal Issue Monitored: prandal
2014-04-04 15:58 enterdavertex Issue Monitored: enterdavertex
2014-04-04 16:04 enterdavertex Note Added: 0001176
2014-04-08 01:24 ovidiu_stanila Note Added: 0001181
2014-04-29 16:07 will_mike Note Added: 0001221
2014-05-05 02:25 ovidiu_stanila Note Added: 0001236
2014-11-25 13:02 travissidelinger Note Added: 0001325
2014-11-26 09:34 mjo Note Added: 0001326
2015-04-07 14:04 abrist Note Added: 0001354
2015-04-07 14:04 abrist Note Edited: 0001354
2015-04-10 11:33 wcreech Note Added: 0001357
2015-04-10 16:01 abrist Note Added: 0001358
2015-05-08 05:10 shashikanth_bussa Note Added: 0001359
2015-07-24 14:39 jfrickson Note Added: 0001370
2015-07-24 14:40 jfrickson Status new => resolved
2015-07-24 14:40 jfrickson Resolution open => fixed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker