Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000519 [Nagios Core] Web Interface minor always 2013-10-24 06:03 2016-09-07 13:56
Reporter MalcolmPreen View Status public  
Assigned To jfrickson
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0000519: Restricted access user sees additional hosts - when viewing hostgroups
Description Problem originally reported at
http://support.nagios.com/forum/viewtopic.php?f=7&t=21794&p=76146#p76106 [^]

In brief, I have set-up a restricted access user, which works fine as far as viewing "hosts" or "services"... but if I view "hostgroups" the output I see includes all of the hostgroups that my viewable hosts are part of... but also the names (and status (up/down)) of the other hosts within those hostgroups (see attached image hostgroups.jpg)

If I click on any of the links for a "non-allowed" host, I get no details - but I don't think I should even see the name / status.

Using hostgroups/Summary - there are also more details than expected... the "Service Summary Status" column shows the total number of services in each hostgroup... as opposed to the total that this user can view.

And even worse is hostgroups/Grid - which shows the name of every service (and its status) for every host (even the "non-allowed" ones).
Additional Information The "Upload File" is a screen shot from my local machine from the "Hostgroups" link. I have other screen shots from Hostgroups/Summary and Hostgroups/Grid which I can also upload.
Tags No tags attached.
Nagios Version 4.0.1
OS CentOS
OS Version 6.4
Attached Files jpg file icon hostgroups.jpg [^] (219,382 bytes) 2013-10-24 06:03

- Relationships
duplicate of 0000619resolvedjfrickson Access control in hostgroups - status.cgi 

-  Notes
(0001422)
gbeltramelli (reporter)
2015-09-24 14:55

Still the same issue in opensuse 12.3 nagios 3.5.1.
(0001645)
jfrickson (manager)
2016-09-07 13:56

This was resolved via commit https://github.com/NagiosEnterprises/nagioscore/commit/d1b3a07ff72ece0d296b153d4d5c8c4543ed96c1. [^] The work was done to fix issue http://tracker.nagios.org/view.php?id=619. [^]

- Issue History
Date Modified Username Field Change
2013-10-24 06:03 MalcolmPreen New Issue
2013-10-24 06:03 MalcolmPreen File Added: hostgroups.jpg
2013-10-24 06:03 MalcolmPreen Nagios Version => 4.0.1
2013-10-24 06:03 MalcolmPreen OS => CentOS
2013-10-24 06:03 MalcolmPreen OS Version => 6.4
2013-11-08 06:18 MalcolmPreen Issue Monitored: MalcolmPreen
2015-09-24 14:55 gbeltramelli Issue Monitored: gbeltramelli
2015-09-24 14:55 gbeltramelli Note Added: 0001422
2015-09-25 12:15 jfrickson Status new => assigned
2015-09-25 12:15 jfrickson Assigned To => nagios_staff
2016-09-07 13:54 jfrickson Assigned To nagios_staff => jfrickson
2016-09-07 13:56 jfrickson Note Added: 0001645
2016-09-07 13:56 jfrickson Relationship added duplicate of 0000619
2016-09-07 13:56 jfrickson Duplicate ID 0 => 619
2016-09-07 13:56 jfrickson Status assigned => resolved
2016-09-07 13:56 jfrickson Fixed in Version => 4.2.2
2016-09-07 13:56 jfrickson Resolution open => fixed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker