Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000511 [Nagios Core] Web Interface trivial always 2013-10-17 11:44 2016-09-07 15:54
Reporter knweiss View Status public  
Assigned To jfrickson
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0000511: The nagios tarball contains two identical jquery copies
Description The nagios tarball contains two identical jQuery copies (and both end up in the nagios RPMs, too!):

# md5sum ./html/js/jquery-1.7.1.min.js ./html/includes/jquery 1.7.1.min.js
ddb84c1587287b2df08966081ef063bf ./html/js/jquery-1.7.1.min.js
ddb84c1587287b2df08966081ef063bf ./html/includes/jquery-1.7.1.min.js

Only the former seems to be referenced (by main.php and status.c):

nagios-4.0.1 # egrep -H -r 'JQUERY_JS|jquery-1.7.1.min.js' .
./html/main.php:<script type="text/javascript" src="js/jquery-1.7.1.min.js"></script>
./cgi/status.c: printf("<script type='text/javascript' src='%s%s'></script>\n",url_js_path, JQUERY_JS);
./include/cgiutils.h:#define JQUERY_JS "jquery-1.7.1.min.js"

Shouldn't a single copy be enough?
Additional Information jQuery 1.7.2 is the latest 1.7.x version.

Also, the 1.7.x branch is old/obsolete. Maybe it would make sense to update to a newer jQuery version: http://jquery.com/download/ [^]
Tags No tags attached.
Nagios Version 4.0.1
OS Red Hat Enterprise Linux (CentOS)
OS Version 5.9
Attached Files

- Relationships
duplicate of 0000682resolvednagios_staff Update jquery 

-  Notes
(0001653)
jfrickson (manager)
2016-09-07 15:54

Duplicate jquery script deletedin 'maint' branch via commit https://github.com/NagiosEnterprises/nagioscore/commit/d80325679544122a1e78d6a0ce93720ad807c467. [^]

The old/obsolete jquery part will be addressed with issue http://tracker.nagios.org/view.php?id=682 [^]

- Issue History
Date Modified Username Field Change
2013-10-17 11:44 knweiss New Issue
2013-10-17 11:44 knweiss Nagios Version => 4.0.1
2013-10-17 11:44 knweiss OS => Red Hat Enterprise Linux (CentOS)
2013-10-17 11:44 knweiss OS Version => 5.9
2015-09-25 12:21 jfrickson Status new => assigned
2015-09-25 12:21 jfrickson Assigned To => nagios_staff
2016-09-07 15:51 jfrickson Assigned To nagios_staff => jfrickson
2016-09-07 15:54 jfrickson Note Added: 0001653
2016-09-07 15:54 jfrickson Relationship added duplicate of 0000682
2016-09-07 15:54 jfrickson Duplicate ID 0 => 682
2016-09-07 15:54 jfrickson Status assigned => resolved
2016-09-07 15:54 jfrickson Fixed in Version => 4.2.2
2016-09-07 15:54 jfrickson Resolution open => fixed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker