Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000491 [Nagios Core] Installation major always 2013-09-23 08:27 2014-03-14 14:34
Reporter arjenheidinga View Status public  
Assigned To swilkerson
Priority normal Resolution fixed  
Status closed   Product Version 3.4.3
Summary 0000491: [INITSCRIPT] Ubuntu 12.04 LTS initscript failure
Description Hello
We compiled nagios 4.0.0 on ubuntu 12.04 however the initscript seemd te be for Redhat based systems, as /etc/init.d/funtions dows not exist.

Attempts to tweak the script have failed. We tried changing the functions to /lib/lsb/init-functions but this had no resert (as the 'daemon' call is undefined there.

The original initscript from the 3.4x.something install did not work either (obviously).
Additional Information
Tags No tags attached.
Nagios Version 4.0.0
OS Ubuntu
OS Version 12.04 LTS
Attached Files ? file icon nagios-init4 [^] (6,031 bytes) 2013-10-09 07:59

- Relationships
has duplicate 0000460closedswilkerson Nagios don't works in Debian 
has duplicate 0000481closedswilkerson Init script don't run into Debian 6 

-  Notes
(0000822)
amprince02 (reporter)
2013-09-24 12:19
edited on: 2013-09-24 13:27

I'm running OpenSUSE 12.3 and had this same issue. I downloaded the 3.51 code and did the 'configure', 'make all' and then 'make install-init' command and it works for me.

So, basically, I'm starting Nagios Core 4 with the 3.51 init script.

The reason I did this is that I noticed in the 3.51 script that there was an if/then statement to look for /etc/init.d/functions and to work without it if need be. Not sure if it'll worth for other distros but it's worth a shot.

(0000862)
arjenheidinga (reporter)
2013-10-09 07:59

My quick and dirty version. You are insane if you use this in production.
I am insane. :)
(0001077)
stevieg2123 (reporter)
2013-12-13 10:50
edited on: 2013-12-30 21:10

I did modify the Nagios3 script for Ubuntu to work with Nagios4. I've uploaded it to Github, and can be accessed here:

https://github.com/curvedental/ubuntu_nagios4_init [^]

(0001086)
mistie710 (reporter)
2013-12-30 15:37

This sounds familiar. See bug 0000553 for an openSUSE 13.1 take on this.
(0001132)
swilkerson (administrator)
2014-03-03 18:24

Fixed in master
http://sourceforge.net/p/nagios/nagioscore/ci/95ee71a7a908fa631a206f83842e926e6b3afd03/ [^]
(0001147)
estanley (administrator)
2014-03-14 14:34

Released in Nagios Core 4.0.4

- Issue History
Date Modified Username Field Change
2013-09-23 08:27 arjenheidinga New Issue
2013-09-23 08:27 arjenheidinga Nagios Version => 4.0.0
2013-09-23 08:27 arjenheidinga OS => Ubuntu
2013-09-23 08:27 arjenheidinga OS Version => 12.04 LTS
2013-09-24 12:19 amprince02 Note Added: 0000822
2013-09-24 13:27 amprince02 Note Edited: 0000822
2013-10-07 07:26 erja Issue Monitored: erja
2013-10-09 07:59 arjenheidinga Note Added: 0000862
2013-10-09 07:59 arjenheidinga File Added: nagios-init4
2013-12-13 10:50 stevieg2123 Note Added: 0001077
2013-12-30 15:37 mistie710 Note Added: 0001086
2013-12-30 15:38 mistie710 Issue Monitored: mistie710
2013-12-30 21:10 stevieg2123 Note Edited: 0001077
2014-03-03 18:24 swilkerson Note Added: 0001132
2014-03-03 18:24 swilkerson Status new => resolved
2014-03-03 18:24 swilkerson Resolution open => fixed
2014-03-03 18:24 swilkerson Assigned To => swilkerson
2014-03-03 18:28 swilkerson Relationship added has duplicate 0000460
2014-03-03 18:28 swilkerson Relationship added has duplicate 0000481
2014-03-14 14:34 estanley Note Added: 0001147
2014-03-14 14:34 estanley Status resolved => closed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker