Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000460 [Nagios Core] Core minor always 2013-06-13 00:31 2014-03-14 14:41
Reporter estebanmonge View Status public  
Assigned To swilkerson
Priority normal Resolution duplicate  
Status closed   Product Version 4.0.0
Summary 0000460: Nagios don't works in Debian
Description When I try to start Nagios in Debian I received this message:
/etc/init.d/nagios: 20: .: Can't open /etc/init.d/functions

If I copy the file to /etc/init.d/functions and modify the line
. /etc/rc.d/init.d/functions
. /etc/init.d/functions

If stop to receive the message, but Nagios never starts.
Additional Information
Tags No tags attached.
Nagios Version 4.0
OS Debian
OS Version 7.0
Attached Files

- Relationships
duplicate of 0000491closedswilkerson [INITSCRIPT] Ubuntu 12.04 LTS initscript failure 

-  Notes
(0000794)
gaellanglais (reporter)
2013-09-03 08:06
edited on: 2013-09-03 08:07

Same issue here on Debian 7.1

I've tried to replace in the script /etc/init.d/nagios:
. /etc/rc.d/init.d/functions
By
. /lib/lsb/init-functions

and get the error:
./nagios: 116: ./nagios: status: not found

Regards.

(0000814)
gaellanglais (reporter)
2013-09-23 08:59

Same issue with the stable version (4.0.0) on Debian 7.1
(0000818)
MagnaVis (reporter)
2013-09-23 23:35

Same issue with stable version (4.0.0) on Ubuntu server 12.04, clean install, following http://assets.nagios.com/downloads/nagioscore/docs/Installing_Nagios_Core_From_Source.pdf [^] to the letter (except the typos).
(0000852)
droopie (reporter)
2013-09-28 19:10

I am having the same issue with opensuse 12.3. new install and new install of Nagios 4 by the book.

any resoltion yet
(0000854)
MagnaVis (reporter)
2013-09-30 17:09
edited on: 2013-09-30 17:09

If you would like to see some of the progress, check this thread: http://support.nagios.com/forum/viewtopic.php?f=7&t=12038 [^]

We helped a little, but I think it's a long way from getting resolved. I wouldn't really be surprised if the resolution was just, "Run it on CentOS or Red Hat." There have been numerous problems with Debian in the past, I think the Nagios team may just not have time to support it properly. We'll see, but I'll probably just stay on 3.5 for now.

(0000869)
gbeltramelli (reporter)
2013-10-15 10:34
edited on: 2013-10-15 10:35

I have tried everything on openSuse 12.3 and i canĀ“t make it work (nagios version 4.0.0)


- Issue History
Date Modified Username Field Change
2013-06-13 00:31 estebanmonge New Issue
2013-06-13 00:31 estebanmonge Nagios Version => 4.0
2013-06-13 00:31 estebanmonge OS => Debian
2013-06-13 00:31 estebanmonge OS Version => 7.0
2013-09-03 08:06 gaellanglais Note Added: 0000794
2013-09-03 08:07 gaellanglais Note Edited: 0000794
2013-09-23 08:59 gaellanglais Note Added: 0000814
2013-09-23 23:35 MagnaVis Note Added: 0000818
2013-09-28 19:10 droopie Note Added: 0000852
2013-09-28 19:10 droopie Issue Monitored: droopie
2013-09-30 17:09 MagnaVis Note Added: 0000854
2013-09-30 17:09 MagnaVis Note Edited: 0000854
2013-10-07 05:16 erja Issue Monitored: erja
2013-10-09 04:50 ps Issue Monitored: ps
2013-10-15 10:34 gbeltramelli Note Added: 0000869
2013-10-15 10:35 gbeltramelli Note Edited: 0000869
2014-03-03 18:28 swilkerson Relationship added duplicate of 0000491
2014-03-03 18:28 swilkerson Duplicate ID 0 => 491
2014-03-03 18:28 swilkerson Status new => resolved
2014-03-03 18:28 swilkerson Resolution open => duplicate
2014-03-03 18:28 swilkerson Assigned To => swilkerson
2014-03-14 14:41 estanley Status resolved => closed
2014-03-14 14:41 estanley Fixed in Version => 4.0.4


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker