Nagios Bug and Feature Tracker
Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000455 [Nagios Core] Core crash sometimes 2013-05-16 06:57 2014-03-10 16:42
Reporter FPastor View Status public  
Assigned To
Priority normal Resolution open  
Status new   Product Version
Summary 0000455: Nagios go down every night when (maybe) logrotate
Description Nagios go down every night when (maybe) logrotate
Additional Information We have create post in support forum for non customers users
http://support.nagios.com/forum/viewtopic.php?f=7&t=10224 [^]

see debug files with last 1000lines before core goes down

in dmesg we have this notification
nagios[22347]: segfault at 0000000100000001 rip 00000038ca079b60 rsp 00007fffcd8a6868 error 4
Tags No tags attached.
Nagios Version 3.5.0
OS Red Hat
OS Version Enterprise Linux Server release 5.7 (Tikanga)
Attached Files txt file icon nagios.debug.1.txt [^] (936,487 bytes) 2013-05-16 06:58
txt file icon nagios.debug.2.txt [^] (918,976 bytes) 2013-05-16 06:58
txt file icon nagios.debug.3.txt [^] (799,155 bytes) 2013-05-16 06:59

- Relationships

-  Notes
(0000786)
iiro (reporter)
2013-08-07 07:35

We have experienced this with version 3.5.0 too - last night... But we didnĀ“t get any segfaults anywhere - Nagios did just report (in it`s log) that it was shutdown at midnight - and nothing after that.

OS: Ubuntu 12.04 LTS running kernel 3.2.0-44-generic.
(0000789)
iiro (reporter)
2013-08-08 01:51

...and happened again.

I will disable log rotation for now.
(0000812)
dekeister (reporter)
2013-09-20 04:34
edited on: 2013-09-20 09:38

Archives logrotate gives SIGSEGV Signal to Nagios
DIstribution : Debian i686 version 7.
Nagios Core : 3.5.0 Installed by compilation of source .
There was no problem during 2 month and one day ...
I am having an issue with nagios and the archive/log rotation. I have
configured "log_rotation_method=d" and when it runs I see a SIGSEGV in the
nagios.log and nagios shutsdown. I can move it to =h and it will do it every
hour (crash). The logfile has nothing else to indicate why it is crashing.

Anyone have suggestions on how to trace down the real problem here? File
permissions on the archive dir are nagios:nagios as is the nagios.log file.

There is no new archive log since this crashdate.
I've set "log_rotation_method=n" because this server is on 24/7 production but i think it isn't the right way
Actually, 53 Day Logs rotate OK, 75% free space on disk.

Did you need any further informations (logs,...)?

(0000816)
awiddersheim (reporter)
2013-09-23 14:00

I ran into this issue in conjunction with the livestatus NEB module after the 3.5.0 release of Nagios or whatever release finally implemented fixes for downtime notifications being resent.

Disabling livestatus or appying this patch should resolve the issue:

http://git.mathias-kettner.de/git/?p=omd.git;a=blob;f=packages/nagios/patches/0007-fix_downtime_struct.dif;h=af0e245b585e78c372a69d10c5e3b47ab64ad510;hb=HEAD [^]

If you aren't using livestatus and this is happening that I'm not sure what the problem is and you'll have to wait for devs to look into it.
(0000861)
hsmade (reporter)
2013-10-08 04:38

That patch fixed it for me
(0001142)
PMDubuc (reporter)
2014-03-10 16:38

I'm also seeing this with Nagios 3.5.1. It seems only to happen when there are services that have a downtime scheduled. I'm using livestatus 1.2.2p3. I haven't tried the patch to the nagios downtime struct. Is that patch safe to use where scheduled downtimes are concerned? Will that patch be incorporated into a future release of 3.5?
(0001143)
awiddersheim (reporter)
2014-03-10 16:42

That patch works for me currently. Been using it in production for several months without any issues. As for it being added to 3.5.1, as far as I know there will no longer be any updates to the 3.x branch and it is encouraged for people to upgrade to 4.x.

- Issue History
Date Modified Username Field Change
2013-05-16 06:57 FPastor New Issue
2013-05-16 06:57 FPastor Nagios Version => 3.5.0
2013-05-16 06:57 FPastor OS => Red Hat
2013-05-16 06:57 FPastor OS Version => Enterprise Linux Server release 5.7 (Tikanga)
2013-05-16 06:58 FPastor File Added: nagios.debug.1.txt
2013-05-16 06:58 FPastor File Added: nagios.debug.2.txt
2013-05-16 06:59 FPastor File Added: nagios.debug.3.txt
2013-06-06 05:29 FPastor Issue Monitored: FPastor
2013-08-07 03:58 iiro Issue Monitored: iiro
2013-08-07 07:35 iiro Note Added: 0000786
2013-08-08 01:51 iiro Note Added: 0000789
2013-09-20 04:34 dekeister Note Added: 0000812
2013-09-20 04:35 dekeister Note Edited: 0000812
2013-09-20 09:38 dekeister Note Edited: 0000812
2013-09-23 14:00 awiddersheim Note Added: 0000816
2013-10-08 04:38 hsmade Note Added: 0000861
2013-10-09 04:51 ps Issue Monitored: ps
2013-11-08 10:32 dvoryanchikov Issue Monitored: dvoryanchikov
2014-03-10 16:38 PMDubuc Note Added: 0001142
2014-03-10 16:38 PMDubuc Issue Monitored: PMDubuc
2014-03-10 16:42 awiddersheim Note Added: 0001143
2014-09-22 03:39 giner Issue Monitored: giner


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker