Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000356 [NSCA] * Feature Request * minor always 2012-07-10 16:08 2016-10-25 16:52
Reporter stefanlasiewski View Status public  
Assigned To nagios_staff
Priority normal Resolution open  
Status closed   Product Version
Summary 0000356: Provide option so nsca-client 2.9 works with existing nsca 2.7 servers
Description It appears that nsca-client 2.9 is not backwards compatible with the nsca 2.7.2 daemon due to a change in . See [1] and [2].

Many NSCA users are running nsca 2.7.2, because that is the latest stable version version available for RHEL, Fedora, Debian, etc. This means that we cannot use nsca-client 2.9 in an environment which has an existing NSCA environment, with 2.7.2. It will be difficult for us to upgrade our NSCA installations a step at a time.

Please add an option so that 2.9 client can send packets which are compatible with existing 2.7 servers. Perhaps an extra flag could be used to ensure that the packet size is compatible with nsca 2.7.2?

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670373 [^]
[2] http://support.nagios.com/forum/viewtopic.php?f=7&t=6401 [^]
Additional Information
Tags No tags attached.
OS CentOS
OS Version 5
Attached Files

- Relationships

-  Notes
(0000506)
stefanlasiewski (reporter)
2012-07-17 16:36

Correction:

> due to a change in

This should say "due to a change in the size of the packet"
(0001763)
jfrickson (manager)
2016-10-25 16:52

Moved to github https://github.com/NagiosEnterprises/nsca/issues/9 [^]

- Issue History
Date Modified Username Field Change
2012-07-10 16:08 stefanlasiewski New Issue
2012-07-10 16:08 stefanlasiewski OS => CentOS
2012-07-10 16:08 stefanlasiewski OS Version => 5
2012-07-17 16:36 stefanlasiewski Note Added: 0000506
2015-09-25 12:15 jfrickson Status new => assigned
2015-09-25 12:15 jfrickson Assigned To => nagios_staff
2016-10-25 16:52 jfrickson Note Added: 0001763
2016-10-25 16:52 jfrickson Status assigned => closed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker