Nagios Bug and Feature Tracker
Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000273 [Nagios Core] Notifications major N/A 2011-11-23 03:47 2012-09-18 00:51
Reporter Anwaar Ahmed View Status public  
Assigned To ageric
Priority normal Resolution no change required  
Status closed   Product Version
Summary 0000273: Additional Info : show blank in mail notification alerts
Description ***** Nagios *****

Notification Type: PROBLEM

Service: PING
Host: Internet Connection
Address: www.******.com
State: WARNING

Date/Time: Mon Nov 21 13:25:19 GMT 2011

Additional Info:



can u please help me out why addtional info not available in mail but in nagios web interface i can see status information
Additional Information define command{
        command_name notify-service-by-email
        command_line /usr/bin/printf "%b" "***** Nagios *****\n\nNotification Type: $NOTIFICATIONTYPE$\n\nService: $SERVICEDESC$\nHost: $HOSTALIAS$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\n\nDate/Time: $LONGDATETIME$\n\nAdditional Info:\n\n$SERVICEOUTPUT$\n" | /usr/bin/mail -s "** $NOTIFICATIONTYPE$ Service Alert: $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$ **" $CONTACTEMAIL$
        }
Tags No tags attached.
Nagios Version Nagios3
OS ubuntu
OS Version 10.4
Attached Files

- Relationships

-  Notes
(0000370)
rambabu_2002 (reporter)
2011-12-08 04:42

The printf template needs a \n at the end in case $SERVICEOUTPUT$ doesn't end with one or else /usr/bin/mail may ignore the last line
(0000604)
ageric (reporter)
2012-09-18 00:51

It could also be that the plugin only printed a space, or didn't print anything at all but still closed its output descriptors in an orderly fashion.

Either way, this is obviously not a bug in Nagios.

- Issue History
Date Modified Username Field Change
2011-11-23 03:47 Anwaar Ahmed New Issue
2011-11-23 03:47 Anwaar Ahmed Nagios Version => Nagios3
2011-11-23 03:47 Anwaar Ahmed OS => ubuntu
2011-11-23 03:47 Anwaar Ahmed OS Version => 10.4
2011-12-08 04:42 rambabu_2002 Note Added: 0000370
2012-09-18 00:50 ageric Status new => assigned
2012-09-18 00:50 ageric Assigned To => ageric
2012-09-18 00:51 ageric Note Added: 0000604
2012-09-18 00:51 ageric Status assigned => closed
2012-09-18 00:51 ageric Resolution open => no change required


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker