Nagios Bug and Feature Tracker
Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000247 [Nagios Core] Performance major always 2011-08-25 04:16 2013-10-17 08:19
Reporter msupino View Status public  
Assigned To estanley
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000247: no perfdata is perfdata is empty
Description If a service reports no performance data, the perfdata log file has no line indicating the test.
Additional Information
Tags No tags attached.
Nagios Version 3.3.1
OS linux
OS Version cen5.6
Attached Files ? file icon nagios-3.4.1-perfdata.patch [^] (4,402 bytes) 2012-06-14 17:03

- Relationships
has duplicate 0000252closedageric no service perfdata line output when perfdata is empty 

-  Notes
(0000327)
msupino (reporter)
2011-08-25 04:26

Fixed Summary : no perfdata if perfdata is empty
(0000397)
pdeneu (reporter)
2012-04-04 04:00

There are any new infromation about.
In my opinion perfdata files should also be writte if perfdata ist empty.
Maybe a little switch in the nagios.cfg would solve this problem.
Icinga has a smiliar function which is very usefull for that:
https://dev.icinga.org/issues/1413 [^]
(0000398)
HPSCH (reporter)
2012-04-04 09:15

I tested these entries, in the File:
/etc/nagios/nagios.cfg

host_perfdata_process_empty_results=1
service_perfdata_process_empty_results=1

but it does not help;
(0000403)
dnsmichi (reporter)
2012-04-09 12:52

without patching & recompiling the binaries setting such config options will not work.

believe me, i'm the author of the mentioned patch.
(0000432)
omnikron (reporter)
2012-05-23 05:11

Hi all,

I just found out that a 3.4.1 had been released recently but the patch from Icinga adding support for host_perfdata_process_empty_results and service_perfdata_process_empty_results was not included.

I believe this is a major bug as it breaks compatibility with previous versions of Nagios. I can't understand why Nagios development team would think differently and not address that particular bug with a high priority.

Here we have a script walking on service perf log file in order to feed RRD databases. The script matches patterns in lines both having and not having perfdata. Take it that some plugins do not follow best practice guidelines, but we still need to update our RRD databases even if the plugin does not provide perfdata and only normal output. Without a fix we will have to stay with 3.2.3, which is now quite old.

Though I must say I haven't tried by myself 3.4.1, but some people reported the problem is still there and that dnsmichi's patch /should/ applies quite well.

Please checkout Icinga GIT repository :
https://git.icinga.org/?p=icinga-core.git;a=commitdiff;h=465f5aa1710f60e41db012ba7915e66fdfdce06e [^]
http://www.rebee.clara.net/xpddefault.diff [^]
(0000489)
prandal (reporter)
2012-06-14 17:06

Attached a patch which brings Nagios in line with Icinga, which is basically dnsmichi's patch from https://dev.icinga.org/issues/1413 [^]

Been running here for the last two weeks without problems
(0000490)
omnikron (reporter)
2012-06-14 17:40

Thanks prandal, hopefully the Nagios team will integrate it soon !
(0000507)
estanley (administrator)
2012-07-18 06:29

Applied to trunk and to nagios-3-x-bugfixes branch.

- Issue History
Date Modified Username Field Change
2011-08-25 04:16 msupino New Issue
2011-08-25 04:16 msupino Nagios Version => 3.3.1
2011-08-25 04:16 msupino OS => linux
2011-08-25 04:16 msupino OS Version => cen5.6
2011-08-25 04:25 msupino Issue Monitored: msupino
2011-08-25 04:26 msupino Note Added: 0000327
2011-09-04 23:54 youngcow Issue Monitored: youngcow
2011-10-07 09:26 ageric Relationship added has duplicate 0000252
2011-10-10 01:19 HPSCH Issue Monitored: HPSCH
2012-04-04 04:00 pdeneu Note Added: 0000397
2012-04-04 09:15 HPSCH Note Added: 0000398
2012-04-09 12:52 dnsmichi Note Added: 0000403
2012-05-23 05:11 omnikron Note Added: 0000432
2012-05-23 05:12 omnikron Issue Monitored: omnikron
2012-06-13 06:25 benoitp Issue Monitored: benoitp
2012-06-14 17:03 prandal File Added: nagios-3.4.1-perfdata.patch
2012-06-14 17:06 prandal Note Added: 0000489
2012-06-14 17:40 omnikron Note Added: 0000490
2012-07-13 06:08 prandal Issue Monitored: prandal
2012-07-17 06:45 estanley Status new => assigned
2012-07-17 06:45 estanley Assigned To => estanley
2012-07-18 06:29 estanley Note Added: 0000507
2012-07-18 06:29 estanley Status assigned => resolved
2012-07-18 06:29 estanley Resolution open => fixed
2012-11-12 18:08 omnikron Issue End Monitor: omnikron
2013-10-17 08:19 estanley Status resolved => closed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker