Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000220 [Nagios Plugins] Other / Unknown minor always 2011-05-18 12:53 2012-09-18 09:11
Reporter durist View Status public  
Assigned To
Priority normal Resolution open  
Status closed  
Summary 0000220: check_snmp does not read snmp.conf files
Description check_snmp does not read snmp.conf files (as the standard UCD-SNMP utilities do), which makes it impossible to use SNMP version 3 without passing the password on the commandline and thus exposing the password in the process table.

This is in check_snmp v1.4.14 (nagios-plugins 1.4.14).
Additional Information
Tags No tags attached.
OS Ubuntu Linux
OS Version Lucid
Attached Files ? file icon nagios-plugins-1.4.15-snmp_conf.patch [^] (7,650 bytes) 2011-07-26 15:16
? file icon nagios-plugins-1.4.15-snmp_conf_final.patch [^] (8,025 bytes) 2011-07-26 15:59

- Relationships

-  Notes
(0000311)
wyztix (reporter)
2011-07-26 15:16

I had to implement this feature off nagios-plugins-1.4.15 since we needed that for our monitoring server.

I am unaware of the normal way to provide patches so I attached it to the ticket itself. I left the error validation to the External command. If an invalid etry is provided, we will receive an exit code of 3 and the error message will appear as "External command error: <error>";

This worked on RHEL5 with NET-SNMP 5.3.2.2-9.
(0000312)
wyztix (reporter)
2011-07-26 16:00

Look like I uploaded the wrong file. The first one (nagios-plugins-1.4.15-snmp_conf.patch) should work for SNMP3. At least, it works on our servers. Yet, I forgot the community string on that first one since we don't use SNMP v2 that much anymore: only for windows. This was solved on the second version: nagios-plugins-1.4.15-snmp_conf_final.patch
(0000525)
calestyo (reporter)
2012-07-31 19:07

Forwarded to: https://sourceforge.net/tracker/?func=detail&aid=3552837&group_id=29880&atid=397597 [^]

- Issue History
Date Modified Username Field Change
2011-05-18 12:53 durist New Issue
2011-05-18 12:53 durist OS => Ubuntu Linux
2011-05-18 12:53 durist OS Version => Lucid
2011-07-26 15:16 wyztix File Added: nagios-plugins-1.4.15-snmp_conf.patch
2011-07-26 15:16 wyztix Note Added: 0000311
2011-07-26 15:16 wyztix Issue Monitored: wyztix
2011-07-26 15:59 wyztix File Added: nagios-plugins-1.4.15-snmp_conf_final.patch
2011-07-26 16:00 wyztix Note Added: 0000312
2012-07-31 19:07 calestyo Note Added: 0000525
2012-09-18 09:11 ageric Status new => closed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker