Nagios Bug and Feature Tracker

All issues moved to NagiosEnterprises Github

Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000159 [NRPE] Installation minor always 2010-07-27 09:41 2015-12-21 13:16
Reporter paulverhoeven View Status public  
Assigned To jfrickson
Priority normal Resolution unable to reproduce  
Status closed   Product Version
Summary 0000159: includefile option doesn't work
Description We like to monitor several cluster resources.
A resource can be active on one of the clusternodes and the resource itself has it's own ip-address and a san-disk.

Our goal is to have an nrpe.cfg file on a clusternode only containing the checks needed for the server itself. Within the file we would like to refer to include files. When the nrpe daemon is starting it has to load the local checks and (if the resource disk is available) the extra checks for the resource.

Example:
/etc/nagios/nrpe.cfg contains the lines:
# System checks
command[check_swap]=/usr/lib/nagios/plugins/check_swap -w 5% -c 10%
# Application checks
include=/apps/ict/nrpe.cfg

/apps/ict/nrpe.cfg contains the line:
command[check_disk]=/usr/lib/nagios/plugins/check_disk -w 10% -c 5% /apps/ict

Unfortunately this concept doesn't work as expected. Only the local checks work, the checks in the include file result in "NRPE: Command 'check_disk not defined ".
Additional Information
Tags No tags attached.
OS SLES
OS Version 11
Attached Files

- Relationships

-  Notes
(0000248)
Meier (reporter)
2010-10-08 12:40

I tested it and it works. What I did, copy the sample command

#command[check_users]=/usr/lib64/nagios/plugins/check_users -w 5 -c 10

in nrpe.conf to a separate file, renamed it to check_users2 to be really sure, included that new file via include=

check_nrpe -H IP -c check_users2

gave the expected result

USERS OK - 1 users currently logged in |users=1;5;10;0

I think this might be a file access issue, maybe it is not readable for the user running nrpe. If an include cannot be read it is logged via syslog.
(0001524)
jfrickson (manager)
2015-12-21 13:16

As Meier did, I move one line out of nrpe.cfg into another file, and it worked fine.

Make sure the include= directive has the full path to the other config file, and that the nrpe user is able to read that file. Check syslog for errors.

If this is still a problem, please reopen or open a new issue.

- Issue History
Date Modified Username Field Change
2010-07-27 09:41 paulverhoeven New Issue
2010-07-27 09:41 paulverhoeven OS => SLES
2010-07-27 09:41 paulverhoeven OS Version => 11
2010-10-08 12:40 Meier Note Added: 0000248
2015-09-25 12:14 jfrickson Status new => assigned
2015-09-25 12:14 jfrickson Assigned To => nagios_staff
2015-12-21 13:13 jfrickson Assigned To nagios_staff => jfrickson
2015-12-21 13:16 jfrickson Note Added: 0001524
2015-12-21 13:16 jfrickson Status assigned => closed
2015-12-21 13:16 jfrickson Resolution open => unable to reproduce


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker