Nagios Bug and Feature Tracker
Bug and Feature Tracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000154 [NDOUtils] NDO2DB minor always 2010-06-21 13:12 2014-03-14 14:57
Reporter VGavara View Status public  
Assigned To mguthrie
Priority normal Resolution fixed  
Status closed   Product Version ndoutils-1.4b9
Summary 0000154: Host 2D Y coord not stored properly
Description Host 2D Y coord is ALWAYS 0 in nagios_hosts table although 2d_coords host attribute was properly defined.

Found in versions 1.4b8 and 1.4b9 (not tested in previous versions)
Additional Information SOLUTION (for 1.4b9 source code):

File dbhandlers.c has a bug in line 3301: instead of assigning the Y 2D coord value to field NDO_DATA_Y2D, it is assigned to field NDO_DATA_Y3D:

result=ndo2db_convert_string_to_int(idi->buffered_input[NDO_DATA_Y3D],&y_2d);

The solution is just replacing NDO_DATA_Y3D by NDO_DATA_Y2D.

Tested and working properly.
Tags No tags attached.
OS Debian
OS Version Etch
Attached Files

- Relationships

-  Notes
(0000434)
mguthrie (reporter)
2012-05-23 11:57

This should be fixed in 1.5.1. The issue was most likely being caused by the "one off" errror which was fixed in commit #1942 by estanley

- Issue History
Date Modified Username Field Change
2010-06-21 13:12 VGavara New Issue
2010-06-21 13:12 VGavara OS => Debian
2010-06-21 13:12 VGavara OS Version => Etch
2012-05-23 11:57 mguthrie Note Added: 0000434
2012-05-23 11:57 mguthrie Status new => resolved
2012-05-23 11:57 mguthrie Resolution open => fixed
2012-05-23 11:57 mguthrie Assigned To => mguthrie
2014-03-14 14:57 estanley Status resolved => closed


Mantis 1.1.7[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker